Updating your NIM master to AIX 7.1 TL2? Take note!After updating my NIM master to AIX 7.1 TL2 SP1 (7100-02-01-1245), I noticed a problem. Whenever I installed a new AIX partition using NIM, the resources allocated to the NIM client were not being de-allocated, even though the installation was completing successfully. Also, if I tried to run my usual ‘NIM client reset’ script (below), the resources were still allocated.
#!/usr/bin/ksh # Reset a NIM client.
if [[ "$1" = "" ]] ; then echo Please specify a NIM client to reset e.g. aixlpar1. else if lsnim -l $1 > /dev/null 2>&1 ; then nim -o reset -F $1 nim -Fo de-allocate -a subclass=all $1 nim -Fo change -a cpuid= $1 else echo Not a valid NIM client!? fi fi For example, here’s my NIM client with the lpp_source, mksysb and SPOT resources assigned to it (even though the AIX install completed OK). root@nim1 :
/ # lsnim -l aixl aixl class = mach type = stan connect = shel platform = chr netboot_kernel = 6 if1 = network1 aixlpar1 0 cable_type1 = N/ Cstate = ready for a NIM oper prev_state = not runn Mstate = currently runn boot = boo
lpp_source =
lpp_
mksysb = aixl nim_script = nim_
spot =
spot cpuid = 00C4 control = mast Cstate_result = succ installed_image = aixl My
workaround was to use 'smit nim_mac_res'
to manually de-allocate resources from
the clie === De-allocate Network Install Reso aixlpar1 machines stan >lpp >spo >aixlpar1-71 mksy === It appears that others were also experiencing this problem. I found the following thread on the IBM developerWorks AIX user forum: NIM de-allocate with subclass=all doesn't work: http
Someone even provided their own version of a ‘NIM client reset’ script that offered another workaround to the problem:
nim -Fo reset $1 for i in bosinst_data fb_script image_data installp_bundle lpp_source mksysb nim_script script spot ; do ress for j in ${re nim -Fo de-allocate -a $i=$j $1 done done I reported the issue to IBM AIX support and discovered that this is a known issue with 7.1 TL2.
“This is a known issue which recently has been documented in 2 open APARs: IV32570 and IV32670: UPDATE NIM BINARIES FOR UPDATES. Error
desc One known symptom (of this issue) is that "nim -Fo de-allocate -a subclass=all <client>" returns successfully but the resource
will still be allo The problem occured because the "update" pack that brings you from 7.1.1.x to 7.1.2.0 missed a piece that effected the bos.sysmgt.7.1.2.0 file Currently there is no fix available and no projected timeframe when this issue will be fixed (i assume it will be with the next SP for AIX 7100 However, a workaround is allready documented in our incidents database -
you simply need to force reinstall the bos. 7.1.2.0
fileset using your AIX 7.1 TL02 medi This is not a backleveling of the fileset, you are simply force overwriting the full base level at the same version that you are currently
at. It will still be at 7100 The
workaround is a force overwrite of the bos. from media."
The AIX support team suggested that I download the necessary install fileset from the following location:
ftp:
I backed up my NIM database before re-installing the fileset, just in case.
---- Starting NIM Database Backup on nim1 at Wed Dec 12 12:39:43 EETDT 2012
a
./et a
./et a
./et a
./et a ./etc/NIM.level 1 blocks. a ./etc/niminfo 1 blocks. a
./et
Finished NIM Database Backup on nim1 at Wed Dec 12 12:39:44 EETDT 2012 ----
I placed the fileset into a separate directory on the NIM master and ran inutoc.
root@nim1 :
/hom total 36170 -rw-r--r-- 1 cgibson
staff 18512896 Dec 12 12:21
bos. -rw-r--r-- 1 root system 4778 Dec 12 12:35 .toc
Then I re-installed the fileset (force OVERWRITE) on the NIM master:
Install Software
Type or select values in entry fields. Press Enter AFTER making all desired changes.
* INPUT
device / directory for soft * SOFTWARE
to inst PREVIEW only? (install operation will NOT occur) no COMMIT software upda SAVE replaced file AUTOMATICALLY install requisite software? no EXTEND file systems if space need OVERWRITE same or newer vers VERIFY install and check file size Include corresponding LANGUAGE filesets? yes DETAILED outp Process multiple volu ACCEPT new license agre Preview new LICENSE agre
The fileset re-installed without a problem.
Installation Summary ---- Nam ---- bos.
root@nim1 :
/hom File
---- Path: /usr/lib/objrepos bos.
I re-tried installing AIX on a NIM client.
root@nim1 : / # lsnim -l aixlpar1 aixlpar1: class = machines type = standalone connect = shell platform = chrp netboot_kernel = 64 if1 = network1 aixlpar1 0 cable_type1 = N/A Cstate = Base Operating System installation is being performed prev_state = BOS installation has been enabled Mstate = in the process of booting info = veri boot = boot lpp_source = lpp_sourceaix710105 mksysb = aixlpar1-71 nim_script = nim_script spot = spotaix710105 cpuid = 00C453C75C00 control = master Cstate_result = success installed_image = aixlpar1-71
Once the install completed I found that all allocated NIM resources (lpp_source, mksysb and SPOT) were de-allocated. Problem solved.
root@nim1 : / # lsnim -l aixlpar1 aixlpar1: class = machines type = standalone connect = shell platform = chrp netboot_kernel = 64 if1 = network1 aixlpar1 0 cable_type1 = N/A Cstate = ready for a NIM operation prev_state = in the process of booting Mstate = not running cpuid = 00C453C75C00 Cstate_result = success installed_image = aixlpar1-71
So if you are planning on updating your NIM master to 7.1 TL2, please take note and make sure you implement the workaround.
|
This behavior was so annoying every time I patched a NIM client...at least now I know I wasn't going crazy. You just saved me a call into IBM Support. Great work!
Great work! Found your post juste before calling in to support. Keep up the good work!
I've found a little gotcha with this fix. At my current site we use NIM to backup our VIO Servers using "nim -o define -t ios_mksysb -a server=master source=XXX -a mk_image=yes -a backupios_flags=-nosvg -a location=XXX XXX". The ios_mksysb resource type is a NIM resource type that is installed by DSM. The force reinstall of bos.sysmgt.nim.master removes the pre-defined NIM types that are added by DSM. An uninstall and re-install of the DSM filesets re-installs the ios_mksysb resource type.
Thanks Chris, I was about to call IBM when I ran into your post. Good work!!
Thanks Chris, I was about to call IBM when I ran into your post. Good work!!
Great post Chris. Luckily I saw it just a few days before the planned date for our infrastructure update... Have a great 2013!
Good Work Chris - it might be worth noting that you do have to use the bos.sysmgt.7.1.2.0.I from the IBM test case, not the one that is in any TLor SP that may have been downloaded. The fileset at IBM Testcase is a base fileset, whilst any download from FixCentral is an update fileset and as such cannot be forced installed. Cheers,