My root volume group is called old_rootvg....HELP!!So, your root volume group is called old_rootvg not rootvg?
Wait……what!?
aixlpar1 : # lspv hdisk0 00c3 hdisk1 00c3
How did you end up in this situation? Did you reinstall AIX with some strange incantation or did some alternate disk activity go horribly wrong? Not sure? Me neither!
Fortunately the following tech-note and associated script can help.
http
“Question Rebuilding a Volume Group's Customized Device Database.
Answer Run the script in this document when the ODM (Object Data Manager) entries for the root volume group are corrupted.”
“The script below assumes you are rebuilding the ODM definitions for the rootvg, which cannot be exported and then re-imported on a live system. For most other volume groups, an export/import is the best way to clean up ODM problems. If you need to rebuild ODM definitions for
volume groups other than the rootvg, substitute appropriate values for PV and
VG.” So here’s the script:
Let’s execute the script to resolve this problem.
Note: Try this on a crash’n’burn system before unleashing it’s fury on a real AIX system (i.e. one that has users that depend on it!). Always take a mksysb backup before performing this type of activity.
aixlpar1 : /tmp # ksh -x fixmyrootvg.ksh + + lslv -l hd5 + grep hdisk + head -1 + awk {print $1} PV=hdisk0 + VG=rootvg + lqueryvg -Lp hdisk0 + awk { print $2 } + read LVname + odmdelete -q name = hd5 -o CuAt 0518-307 odmdelete: 5 objects deleted. + odmdelete -q name = hd5 -o CuDv 0518-307 odmdelete: 1 objects deleted. + odmdelete -q value3 = hd5 -o CuDvDr 0518-307 odmdelete: 1 objects deleted. + odmdelete -q dependency = hd5 -o CuDep 0518-307 odmdelete: 1 objects deleted. + read LVname + odmdelete -q name = hd6 -o CuAt 0518-307 odmdelete: 4 objects deleted. + odmdelete -q name = hd6 -o CuDv 0518-307 odmdelete: 1 objects deleted. + odmdelete -q value3 = hd6 -o CuDvDr 0518-307 odmdelete: 1 objects deleted. + odmdelete -q dependency = hd6 -o CuDep 0518-307 odmdelete: 1 objects deleted. + read LVname + odmdelete -q name = hd8 -o CuAt 0518-307 odmdelete: 3 objects deleted. + odmdelete -q name = hd8 -o CuDv 0518-307 odmdelete: 1 objects deleted. + odmdelete -q value3 = hd8 -o CuDvDr 0518-307 odmdelete: 1 objects deleted. + odmdelete -q dependency = hd8 -o CuDep 0518-307 odmdelete: 1 objects deleted. + read LVname + odmdelete -q name = hd4 -o CuAt 0518-307 odmdelete: 5 objects deleted. + odmdelete -q name = hd4 -o CuDv 0518-307 odmdelete: 1 objects deleted. + odmdelete -q value3 = hd4 -o CuDvDr 0518-307 odmdelete: 1 objects deleted. + odmdelete -q dependency = hd4 -o CuDep 0518-307 odmdelete: 1 objects deleted. + read LVname + odmdelete -q name = hd2 -o CuAt 0518-307 odmdelete: 5 objects deleted. + odmdelete -q name = hd2 -o CuDv 0518-307 odmdelete: 1 objects deleted. + odmdelete -q value3 = hd2 -o CuDvDr 0518-307 odmdelete: 1 objects deleted. + odmdelete -q dependency = hd2 -o CuDep 0518-307 odmdelete: 1 objects deleted. + read LVname + odmdelete -q name = hd9var -o CuAt 0518-307 odmdelete: 5 objects deleted. + odmdelete -q name = hd9var -o CuDv 0518-307 odmdelete: 1 objects deleted. + odmdelete -q value3 = hd9var -o CuDvDr 0518-307 odmdelete: 1 objects deleted. + odmdelete -q dependency = hd9var -o CuDep 0518-307 odmdelete: 1 objects deleted. + read LVname + odmdelete -q name = hd3 -o CuAt 0518-307 odmdelete: 5 objects deleted. + odmdelete -q name = hd3 -o CuDv 0518-307 odmdelete: 1 objects deleted. + odmdelete -q value3 = hd3 -o CuDvDr 0518-307 odmdelete: 1 objects deleted. + odmdelete -q dependency = hd3 -o CuDep 0518-307 odmdelete: 1 objects deleted. + read LVname + odmdelete -q name = hd1 -o CuAt 0518-307 odmdelete: 5 objects deleted. + odmdelete -q name = hd1 -o CuDv 0518-307 odmdelete: 1 objects deleted. + odmdelete -q value3 = hd1 -o CuDvDr 0518-307 odmdelete: 1 objects deleted. + odmdelete -q dependency = hd1 -o CuDep 0518-307 odmdelete: 1 objects deleted. + read LVname + odmdelete -q name = hd10opt -o CuAt 0518-307 odmdelete: 5 objects deleted. + odmdelete -q name = hd10opt -o CuDv 0518-307 odmdelete: 1 objects deleted. + odmdelete -q value3 = hd10opt -o CuDvDr 0518-307 odmdelete: 1 objects deleted. + odmdelete -q dependency = hd10opt -o CuDep 0518-307 odmdelete: 1 objects deleted. + read LVname + odmdelete -q name = local -o CuAt 0518-307 odmdelete: 4 objects deleted. + odmdelete -q name = local -o CuDv 0518-307 odmdelete: 1 objects deleted. + odmdelete -q value3 = local -o CuDvDr 0518-307 odmdelete: 1 objects deleted. + odmdelete -q dependency = local -o CuDep 0518-307 odmdelete: 1 objects deleted. + read LVname + odmdelete -q name = hd7 -o CuAt 0518-307 odmdelete: 3 objects deleted. + odmdelete -q name = hd7 -o CuDv 0518-307 odmdelete: 1 objects deleted. + odmdelete -q value3 = hd7 -o CuDvDr 0518-307 odmdelete: 1 objects deleted. + odmdelete -q dependency = hd7 -o CuDep 0518-307 odmdelete: 1 objects deleted. + read LVname + odmdelete -q name = hd11admin -o CuAt 0518-307 odmdelete: 5 objects deleted. + odmdelete -q name = hd11admin -o CuDv 0518-307 odmdelete: 1 objects deleted. + odmdelete -q value3 = hd11admin -o CuDvDr 0518-307 odmdelete: 1 objects deleted. + odmdelete -q dependency = hd11admin -o CuDep 0518-307 odmdelete: 1 objects deleted. + read LVname + odmdelete -q name = rootvg -o CuAt 0518-307 odmdelete: 3 objects deleted. + odmdelete -q parent = rootvg -o CuDv 0518-307 odmdelete: 0 objects deleted. + odmdelete -q name = rootvg -o CuDv 0518-307 odmdelete: 1 objects deleted. + odmdelete -q name = rootvg -o CuDep 0518-307 odmdelete: 0 objects deleted. + odmdelete -q dependency = rootvg -o CuDep 0518-307 odmdelete: 0 objects deleted. + [ rootvg = rootvg ] + odmdelete -q value1 = 10 -o CuDvDr 0518-307 odmdelete: 1 objects deleted. + odmdelete -q value3 = rootvg -o CuDvDr 0518-307 odmdelete: 0 objects deleted. + importvg -y rootvg hdisk0 rootvg 0516-012 lvaryoffvg: Logical volume must be closed. If the logical volume contains a filesystem, the umount command will close the LV device. 0516-942 varyoffvg: Unable to vary off volume group rootvg. + varyonvg rootvg + synclvodm -Pv rootvg synclvodm: Physical volume data updated. synclvodm: Logical volume hd5 updated. synclvodm: Logical volume hd6 updated. synclvodm: Logical volume hd8 updated. synclvodm: Logical volume hd4 updated. synclvodm: Logical volume hd2 updated. synclvodm: Logical volume hd9var updated. synclvodm: Logical volume hd3 updated. synclvodm: Logical volume hd1 updated. synclvodm: Logical volume hd10opt updated. synclvodm: Logical volume hd7 updated. synclvodm: Logical volume hd11admin updated. + savebase
Hey Presto! The root volume group is now named rootvg just the way we like it!
aixlpar1 : # lspv hdisk0 00c3 hdisk1 00c3
|
3. Once the script finishes run: # sysdumpdev -e # synclvodm -Pv rootvg # sysdumpdev -l
Whoa! My comment got all scrambled.
2.Copy this script into a file then run it.
ODMDIR=/etc/objrepos odmadd <
Yes,
there is something wrong with the ODM entries in SWservAt. Is this the
only command that is reporting unexpected output? How about lsvg, lspv
or lslv?
Are they reporting good information?
Is the root file system full? You need to make sure you don't have a
bigger issue (i.e. wide spread ODM corruption) than just these errors.
Any errors reported by errpt?
Try running.
# synclvodm -Pv rootvg
Then try sysdumpdev again.
If that doesn't help, check if the ODM entries exist in SWservAt:
# odmget SWservAt | grep -p force_system_dump
SWservAt:
attribute = "force_system_dump"
deflt = "TRUE"
value = "TRUE"
SWservAt:
attribute = "force_system_dump"
deflt = "FALSE"
value = "FALSE"
# odmget SWservAt | grep -p fullmem
SWservAt:
attribute = "fullmem_dump"
deflt = "disallow"
value = "disallow"
If they are missing from SWservAt then you may need to add them:
1. Make a backup of your SWservAt object classes.
# cp /etc/objrepos/SW* /tmp/SWservAt.back
2.Copy this script into a file then run it.
ODMDIR=/etc/objrepos odmadd <
Hi Chris, I am getting below error on AIX 7.1 lpar root@:/# sysdumpdev -l Unable to get force_system_dump attribute from ODM object class SWservAt. Unable to get fullmem_dump attribute from ODM object class SWservAt. is there any problem with ODM Entries kindly revert.