In this example, we will use the VIOS VML
to apply SP2 to an AIX 7.2 TL1 SP1 system. This procedure assumes that
the LPAR and the VIOS are both on the same Power System.
1. On any AIX 7.x system (or any OS that can create ISO
images of files). Create a directory containing AIX 7.2 TL1 SP2 update
filesets. Create a toc file in that directory. Create another empty
directory where the ISO image will be stored (ensure it has enough space
to hold the image file).
[root@750lpar4]/export/nim/lpp_source # mkdir aix72tl1_sp2_only
[root@750lpar4]/export/nim/lpp_source # cd aix72tl1_sp2_only
[root@750lpar4]/export/nim/lpp_source/aix72tl1_sp2_only # inutoc .
root@750lpar4]/export/nim/lpp_source/aix72tl1_sp2_only # ls -ltr | tail -3
-rw-r--r-- 1 root system 146906112 Jun 09 13:54 Java71.jre.7.1.0.401.U
-rw-r--r-- 1 root system 168397824 Jun 09 13:54 Java7_64.jre.7.0.0.601.U
-rw-r--r-- 1 root system 309127 Jul 19 12:24 .toc
[root@750lpar4]/export/nim/lpp_source/aix72tl1_sp2_only # cd
[root@750lpar4]/ # mkdir /export/mksysb/cg/aix72tl1_sp2_only_ISO
[root@750lpar4]/ # ls -ltr /export/mksysb/cg/aix72tl1_sp2_only_ISO
total 0
2. Use the mkdvd command to create an ISO image of the
directory. The ISO file will be created in this location. In the example
below the ISO file is named cd_image_27984148 during creation. On AIX,
you can check the integrity of the ISO file by mounting it with the
loopmount command and view the contents.
[root@750lpar4]/ # mkdvd -r /export/nim/lpp_source/aix72tl1_sp2_only -S -I /export/mksysb/cg/aix72tl1_sp2_only_ISO
Initializing mkdvd log: /var/adm/ras/mkcd.log...
Verifying command parameters...
Creating Rock Ridge format image: /export/mksysb/cg/aix72tl1_sp2_only_ISO/cd_image_27984148
Running mkisofs ...
..
mkrr_fs was successful.
[root@750lpar4]/export/mksysb/cg/aix72tl1_sp2_only_ISO # loopmount -i cd_image_27984148 -o "-V cdrfs -o ro" -m /mnt
[root@750lpar4]/export/mksysb/cg/aix72tl1_sp2_only_ISO # df | grep loop
/dev/loop1 3594080 0 100% 898520 100% /mnt
[root@750lpar4]/export/mksysb/cg/aix72tl1_sp2_only_ISO # ls -ltr /mnt
total 3593928
-r--r--r-- 1 root system 49152 Jun 09 13:53 glvm.rpv.msg.ja_JP.7.2.1.0.I
-r--r--r-- 1 root system 38912 Jun 09 13:53 glvm.rpv.msg.en_US.7.2.1.0.I
-r--r--r-- 1 root system 49152 Jun 09 13:53 glvm.rpv.msg.Ja_JP.7.2.1.0.I
…etc…
# umount /mnt
3. Login to the VIOS (padmin) and copy (scp) the ISO
file to the VIOS media library. Ensure there is enough free disk space
for the ISO image file.
[root@750lpar4]/ # ssh padmin@750vio1
Last unsuccessful login: Thu Apr 27 13:56:21 AEST 2017 on /dev/vty0
Last login: Fri Jul 21 10:12:00 AEST 2017 on ssh from 750lpar4
$ whoami
padmin
$ oem_setup_env
# cd /var/vio/VMLibrary
# scp 750lpar4:/export/mksysb/cg/aix72tl1_sp2_only_ISO/cd_image_27984148 .
root@10.1.50.34's password:
cd_image_27984148 100% 1755MB 35.1MB/s 00:50
# ls -ltr
total 35371496
drwxr-xr-x 2 root system 256 Apr 06 2010 lost+found
-r-------- 1 root staff 3774406656 Jun 30 2010 rhel5.5_ppc
-r-------- 1 root staff 1676541952 Jun 30 2010 toolkit
-r-------- 1 root staff 3272192000 Nov 26 2013 rhel64
-r--r--r-- 1 root system 3378020352 Jan 18 2017 AIX_v7.2_DVD_1.iso
-r--r--r-- 1 root system 4168876032 Jan 18 2017 AIX_v7.2_DVD_2.iso
-rw-r--r-- 1 root staff 1840168960 Jul 24 12:36 cd_image_27984148
4. Rename the image file to something more meaningful. Change the permissions to read only for the owner.
# mv cd_image_27984148 AIX7.2TL1SP2update_only
# chmod 400 AIX7.2TL1SP2update_only
# ls -ltr AIX7.2TL1SP2update_only
-r-------- 1 root staff 1840168960 Jul 24 12:36 AIX7.2TL1SP2update_only
5. Verify the ISO appears in the lsrep output on the VIOS.
# exit
$ whoami
padmin
$ lsrep
Size(mb) Free(mb) Parent Pool Parent Size Parent Free
25497 8224 rootvg 279552 132096
Name File Size Optical Access
AIX7.2TL1SP2update_only 1755 None ro
AIX_v7.2_DVD_1.iso 3222 vtopt4 ro
AIX_v7.2_DVD_2.iso 3976 None ro
rhel5.5_ppc 3600 None ro
rhel64 3121 None ro
toolkit 1599 None ro
$
6. To update an LPAR using the image file in the
library, assign a virtual optical device and load the ISO image to the
LPAR. In this example, vhost36 is one of the VSCSI adapters assigned to
the LPAR that is to be updated. A new virtual optical device will be
created. Load the ISO image into this vopt device (vopt5 in this
example).
On the AIX LPAR:
root@cgaix / # echo cvai | kdb -script | grep vio
vscsi0 0x000007 0x0000000000 0x0 750vio1->vhost37
vscsi1 0x000007 0x0000000000 0x0 750vio1->vhost36
On the VIOS:
$ mkvdev -fbo -vadapter vhost36
vtopt5 Available
$ loadopt -disk AIX7.2TL1SP2update_only -vtd vtopt5
$ lsrep | grep only
AIX7.2TL1SP2update_only 1755 vtopt5 ro
7. On the LPAR to be updated, configure the virtual cdrom device (cd0).
root@cgaix / # lsdev -Cc cdrom
root@cgaix / #
root@cgaix / # cfgmgr
root@cgaix / # lsdev -Cc cdrom
cd0 Available Virtual SCSI Optical Served by VIO Server
8. Apply SP2 on the LPAR using the virtual CD device (cd0).
PREVIEW (using smit update_all or update_all...)
root@cgaix / # update_all -pvV -d /dev/cd0
install_all_updates: Initializing system parameters.
install_all_updates: Log file is /var/adm/ras/install_all_updates.log
install_all_updates: Checking for updated install utilities on media.
install_all_updates: Updating install utilities to latest level on media.
*******************************************************************************
installp PREVIEW: installation will not actually occur.
*******************************************************************************
+-----------------------------------------------------------------------------+
Pre-installation Verification...
+-----------------------------------------------------------------------------+
Verifying selections...done
Verifying requisites...done
Results...
SUCCESSES
---------
Filesets listed in this section passed pre-installation verification
and will be installed.
-- Filesets are listed in the order in which they will be installed.
-- The reason for installing each fileset is indicated with a keyword
in parentheses and explained by a "Success Key" following this list.
-- If a fileset has requisites they are listed (indented)
beneath the fileset.
bos.rte.install 7.2.1.3 (Mandatory)
LPP Install Commands
...etc...
92 Selected to be installed, of which:
1 Passed pre-installation verification
91 Deferred (see *NOTE below)
----
1 Total to be installed
...etc...
******************************************************************************
End of installp PREVIEW. No apply operation has actually occurred.
******************************************************************************
install_all_updates: ATTENTION, a higher level of install utilities is
available. The preview option will be more accurate and complete after
updating to the latest level (see the -i option).
install_all_updates: Log file is /var/adm/ras/install_all_updates.log
install_all_updates: Result = SUCCESS
root@cgaix / #
ACTUAL INSTALL/UPDATE (using smit update_all or update_all...)
root@cgaix / # update_all -vV -d /dev/cd0
...etc...
X11.compat.lib.X11R6_motif 7.2.1.1 USR APPLY SUCCESS
Java7_64.sdk 7.0.0.601 USR APPLY SUCCESS
Java7_64.jre 7.0.0.601 USR APPLY SUCCESS
Java7_64.jre 7.0.0.601 ROOT APPLY SUCCESS
installp: * * * A T T E N T I O N ! ! !
Software changes processed during this session require this system
and any of its diskless/dataless clients to be rebooted in order
for the changes to be made effective.
* * * A T T E N T I O N * * *
System boot image has been updated. You must reboot the system
after install_all_updates completes to properly integrate the updates.
install_all_updates: Checking for recommended maintenance level 7200-01.
install_all_updates: Executing /usr/bin/oslevel -rf, Result = 7200-01
install_all_updates: Verification completed.
install_all_updates: Log file is /var/adm/ras/install_all_updates.log
install_all_updates: Result = SUCCESS
root@cgaix / #
9. Once the update is completed successfully, you can
remove the cd0 device from the LPAR and the vtopt device on the VIOS.
Or, if you plan on performing more updates, you can choose to leave the
devices in place. However, this will prevent you from using LPM, should
you need to, in the future; at which time you would need to remove the
devices before migrating them to another frame. You can also remove the
ISO image file from the VIOS VML when you're done using it, if you wish.
On the AIX LPAR:
root@cgaix / # rmdev -dl cd0
cd0 deleted
On the VIOS:
$ rmdev -dev vtopt5
vtopt5 deleted
$ r oem
# cd /var/vio/VMLibrary
# rm AIX7.2TL1SP2update_only