In November 2012, the “What's new in IBM Workload Partitions for AIX” web page was updated with information on System Copy WPARs. They are described as follows:

 

“A system copy WPAR is a system WPAR that is created by copying the files from the root volume group of an existing AIX system or an AIX system backup image.”

 

So, you can either use a mksysb image of an LPAR or use an LPARs current rootvg to create a WPAR. This is interesting. The main difference between this type of WPAR and a standard shared system WPAR is the fact that the System Copy WPAR uses the existing configuration files to create the instance. Files such as /etc/passwd, /etc/hosts and so on, are copied in to the new WPAR. A standard shared system WPAR would create a fresh AIX instance e.g. no users, no entries in /etc/hosts, etc.; you’d need to configure everything from scratch.

 

“A system copy WPAR contains configured files and file systems directly from its source. A system copy WPAR differs from a standard system WPAR because it contains the files and file systems from the root volume group of the source system. A standard WPAR is created as a newly installed system by installing new and unconfigured root parts of filesets into a default set of files.”

 

Let’s try it. I’ll create a new System Copy WPAR using a mksysb image of my AIX 7.1 LPAR. I have existing user accounts on the LPAR (gibbo) and I want this (along with other system configuration) to be migrated across to the new WPAR.

 

aixlpar1 / # oslevel -s

7100-02-02-1316

 

aixlpar1 / # cat /etc/passwd

root:!:0:0::/:/usr/bin/ksh

daemon:!:1:1::/etc:

bin:!:2:2::/bin:

sys:!:3:3::/usr/sys:

adm:!:4:4::/var/adm:

uucp:!:5:5::/usr/lib/uucp:

guest:!:100:100::/home/guest:

nobody:!:4294967294:4294967294::/:

lpd:!:9:4294967294::/:

lp:*:11:11::/var/spool/lp:/bin/false

invscout:*:6:12::/var/adm/invscout:/usr/bin/ksh

snapp:*:200:13:snapp login user:/usr/sbin/snapp:/usr/sbin/snappd

ipsec:*:201:1::/etc/ipsec:/usr/bin/ksh

nuucp:*:7:5:uucp login user:/var/spool/uucppublic:/usr/sbin/uucp/uucico

pconsole:*:8:0::/var/adm/pconsole:/usr/bin/ksh

esaadmin:*:10:0::/var/esa:/usr/bin/ksh

dradmin:!:202:1::/home/dradmin:/usr/bin/ksh

sshd:*:203:201::/var/empty:/usr/bin/ksh

gibbo:!:20008904:1::/home/gibbo:/usr/bin/ksh

 

There are no WPARs on the system. We create a mksysb image of the LPAR (mksysb-7100-02-02-1316).

 

aixlpar1 / # lswpar

aixlpar1 / #

 

aixlpar1 / # mksysb -i /datafs/mksysb-7100-02-02-1316

 

The System Copy WPAR is created with the following mkwpar command (specifying the LPAR mksysb image).

 

aixlpar1 / # mkwpar -t -B /datafs/mksysb-7100-02-02-1316 -n wpar1

 

The WPAR is active.

 

aixlpar1 / # lswpar

Name   State  Type  Hostname  Directory     RootVG WPAR

--------------------------------------------------------

wpar1  A      S     wpar1     /wpars/wpar1  no

 

Let’s connect to my new System Copy WPAR. Look at that! My user account has been automatically restored. Very nice!

 

aixlpar1 / # clogin wpar1

Last unsuccessful login: Wed Jul  6 14:26:00 CDT 2011 on /dev/vty0 from XYZsystem

Last login: Sun Sep 22 20:23:17 CDT 2013 on /dev/Global from aixlpar1

 

wpar1[/] > oslevel -s

7100-02-02-1316

 

wpar1[/] > cat /etc/passwd

root:!:0:0::/:/usr/bin/ksh

daemon:!:1:1::/etc:

bin:!:2:2::/bin:

sys:!:3:3::/usr/sys:

adm:!:4:4::/var/adm:

uucp:!:5:5::/usr/lib/uucp:

guest:!:100:100::/home/guest:

nobody:!:4294967294:4294967294::/:

lpd:!:9:4294967294::/:

lp:*:11:11::/var/spool/lp:/bin/false

invscout:*:6:12::/var/adm/invscout:/usr/bin/ksh

snapp:*:200:13:snapp login user:/usr/sbin/snapp:/usr/sbin/snappd

ipsec:*:201:1::/etc/ipsec:/usr/bin/ksh

nuucp:*:7:5:uucp login user:/var/spool/uucppublic:/usr/sbin/uucp/uucico

pconsole:*:8:0::/var/adm/pconsole:/usr/bin/ksh

esaadmin:*:10:0::/var/esa:/usr/bin/ksh

dradmin:!:202:1::/home/dradmin:/usr/bin/ksh

sshd:*:203:201::/var/empty:/usr/bin/ksh

gibbo:!:20008904:1::/home/gibbo:/usr/bin/ksh

 

If you compare this with a standard shared system WPAR, you’ll observe that important configuration data, such as my user account information is not migrated to the new WPAR instance.

 

aixlpar1 / # clogin wpar2

 

# cat /etc/passwd

root:!:0:0::/:/usr/bin/ksh

daemon:!:1:1::/etc:

bin:!:2:2::/bin:

sys:!:3:3::/usr/sys:

adm:!:4:4::/var/adm:

uucp:!:5:5::/usr/lib/uucp:

guest:!:100:100::/home/guest:

nobody:!:4294967294:4294967294::/:

lpd:!:9:4294967294::/:

lp:*:11:11::/var/spool/lp:/bin/false

snapp:*:200:13:snapp login user:/usr/sbin/snapp:/usr/bin/ksh

nuucp:*:7:5:uucp login user:/var/spool/uucppublic:/usr/sbin/uucp/uucico

invscout:*:6:12::/var/adm/invscout:/usr/bin/ksh

sshd:*:203:201::/var/empty:/usr/bin/ksh

ipsec:*:201:1::/etc/ipsec:/usr/bin/ksh

 

# cd ~gibbo

ksh: ~gibbo:  not found.

#

 

This new feature appears to be an efficient method of converting/migrating existing LPARs in to WPARs. This may advantage customers that are considering WPARs for their AIX environment and have been looking for an easy way to transition to a WPAR strategy.  If you have existing AIX 6.1 and/or 7.1 LPARs at recent TL levels, this may be something to think about.

You can find more information about System Copy WPARs, here:

 

http://pic.dhe.ibm.com/infocenter/aix/v7r1/index.jsp?topic=%2Fcom.ibm.aix.wpar%2Fsystemcopy-wparstop.htm