I created my first versioned AIX 5.2 WPAR on AIX 7 today. To get me started, I followed the steps in the following guide from the AIX 7 Open Beta On-line Information Centre:

http://publib.boulder.ibm.com/infocenter/aix/v7r1/index.jsp?topic=/com.ibm.aix.cre/creconfig-create-wpar.htm

In order to create the WPAR, I needed an AIX 5.2 mksysb file to supply to the mkwpar command.

Fortunately, I just happened to have an old AIX 5.2 mksysb image in my archives!

I then executed the following command to build the WPAR:

# mkwpar -n wpar1 -C -B /home/cgibson/AIX5202_64bit-mksysb

The flags to the command are:

-n wparname

Specifies the name for the workload partition to be created. You must specify a name, either using the -n flag or in a specification file using the -f flag, unless the -p name or both w and -o flags are used.

-B wparbackupdevice

Specifies a device containing a workload partition backup image. This image is used to populate the workload partition file systems. The wparBackupDevice parameter is a workload partition image that is created with the savewpar, mkcd, or mkdvd command. The -B flag is used by the restwpar command as part of the process of creating a workload partition from a backup image.

-C

Creates a versioned workload partition. This option is valid only when additional versioned workload partition software has been installed.

I was then able to start my new AIX 5.2 WPAR successfully!

# startwpar -v wpar1

Starting workload partition wpar1.

Mounting all workload partition file systems.

Mounting /wpars/wpar1

Mounting /wpars/wpar1/home

Mounting /wpars/wpar1/mksysb

Mounting /wpars/wpar1/nre/opt

Mounting /wpars/wpar1/nre/sbin

Mounting /wpars/wpar1/nre/usr

Mounting /wpars/wpar1/opt

Mounting /wpars/wpar1/proc

Mounting /wpars/wpar1/tmp

Mounting /wpars/wpar1/usr

Mounting /wpars/wpar1/usr/local

Mounting /wpars/wpar1/var

Mounting /wpars/wpar1/var/log

Mounting /wpars/wpar1/var/tsm/log

Loading workload partition.

Exporting workload partition devices.

Exporting workload partition kernel extensions.

Starting workload partition subsystem cor_wpar1.

0513-059 The cor_wpar1 Subsystem has been started. Subsystem PID is 8388822.

Verifying workload partition startup.

Return Status = SUCCESS.

The WPAR was now in an active state and the associated file systems were mounted (as shown from the Global environment).

# lswpar

Name State Type Hostname Directory RootVG WPAR

--------------------------------------------------------

wpar1 A S wpar1 /wpars/wpar1 no

# mount | grep wpar

/dev/lv00 /wpars/wpar1 jfs Jul 26 20:13 rw,log=/dev/loglv00

/dev/lv01 /wpars/wpar1/home jfs Jul 26 20:13 rw,log=/dev/loglv00

/dev/lv02 /wpars/wpar1/mksysb jfs Jul 26 20:13 rw,log=/dev/loglv00

/opt /wpars/wpar1/nre/opt namefs Jul 26 20:13 ro

/sbin /wpars/wpar1/nre/sbin namefs Jul 26 20:13 ro

/usr /wpars/wpar1/nre/usr namefs Jul 26 20:13 ro

/dev/lv03 /wpars/wpar1/opt jfs Jul 26 20:13 rw,log=/dev/loglv00

/proc /wpars/wpar1/proc namefs Jul 26 20:13 rw

/dev/lv04 /wpars/wpar1/tmp jfs Jul 26 20:13 rw,log=/dev/loglv00

/dev/lv05 /wpars/wpar1/usr jfs Jul 26 20:13 rw,log=/dev/loglv00

/dev/lv06 /wpars/wpar1/usr/local jfs Jul 26 20:13 rw,log=/dev/loglv00

/dev/lv07 /wpars/wpar1/var jfs Jul 26 20:13 rw,log=/dev/loglv00

/dev/lv08 /wpars/wpar1/var/log jfs Jul 26 20:13 rw,log=/dev/loglv00

/dev/lv09 /wpars/wpar1/var/tsm/log jfs Jul 26 20:13 rw,log=/dev/loglv00

I was curious what the WPAR environment was going to look like, so I used clogin to access it and run a few commands.

From the Global environment I confirmed I was indeed on an AIX 7 system.

# uname -W

0

# oslevel

V7BETA

From within the WPAR, I confirmed that I was indeed running AIX 5.2! Wow!

# clogin wpar1

wpar1 : / # oslevel

5.2.0.0

And I could see all 8 logical CPUs (4 hardware threads per POWER7 processor i.e. SMT-4).

wpar1 : / # sar -P ALL 1 5

AIX wpar1 2 5 00F602734C00 07/26/10

wpar1 configuration: @lcpu=8 @mem=4096MB @ent=0.50

20:22:20 cpu %usr %sys %wio %idle physc %entc

20:22:21 0 7 78 1 14 0.01 0.0

1 1 70 0 29 0.01 0.0

2 0 1 0 99 0.00 0.0

3 0 0 0 100 0.01 0.0

4 0 35 0 65 0.00 0.0

7 0 28 0 72 0.00 0.0

U - - 0 93 0.47 93.9

- 0 3 0 97 0.03 0.0

I noticed an interesting device in the lscfg output.

wpar1 : / # lscfg

INSTALLED RESOURCE LIST

The following resources are installed on the machine.

+/- = Added or deleted from Resource List.

* = Diagnostic support not available.

Model Architecture: chrp

Model Implementation: Multiple Processor, PCI bus

+ sys0 System Object

* wio0 WPAR I/O Subsystem

Also noticed some new and interesting mount points, for example /nre/opt.

wpar1 : / # df

Filesystem 512-blocks Free %Used Iused %Iused Mounted on

Global 131072 99928 24% 1424 5% /

Global 131072 126704 4% 70 1% /home

Global 1048576 1015560 4% 17 1% /mksysb

Global 786432 428904 46% 7331 14% /nre/opt

Global 458752 88400 81% 10020 47% /nre/sbin

Global 4980736 24872 100% 53698 87% /nre/usr

Global 131072 63800 52% 1640 11% /opt

Global - - - - - /proc

Global 131072 125080 5% 52 1% /tmp

Global 1572864 165744 90% 23183 12% /usr

Global 524288 494464 6% 154 1% /usr/local

Global 131072 111512 15% 493 4% /var

Global 262144 253744 4% 28 1% /var/log

Global 131072 126832 4% 20 1% /var/tsm/log

I did have one minor problem when I first tried to start my WPAR, but that issue was quickly resolved by the AIX developers on the AIX 7 Open Beta Forum.

https://www.ibm.com/developerworks/forums/thread.jspa?threadID=335415&tstart=0

Such a fast response to my query demonstrates IBMs commitment to the Open Beta program.

I was notified this morning that Ive been selected to work on an upcoming AIX Redbook in Austin, Texas. Im really looking forward to it.

AIX Differences Guide, PW-0001-R01: http://www.redbooks.ibm.com/residents.nsf/50da6a28780ffa688525701b004a4f21/9032e219ecda947c852576f900691af5?OpenDocument

Follow me on Twitter: http://twitter.com/cgibbo